2017-03-31

Buscar cadena de texto en todos los ficheros de una carpeta con RStudio

Title

Problema

Necesitamos identificar una cadena de texto en algunos de nuestros R scripts. Por ejemplo: un paquete, función o nombre de in objeto. Con Find dentro del menú Edit solamente podemos encontrar las ocurrencias dentro del R script activo.

Solución

  1. Utilizamos la opción Find in Files dentro de menú Edit: Ctrl + Mayús + F.
  2. En el menú emergente tecleamos la cadena de búsqueda (ggplot en nuestro ejemplo) y podemos seleccionar:

    - Que distinga entre mayúculas y minúsculas.
    - Usar expresiones regulares (regular expressions o regex).
    - La carpeta de búsqueda.
    - Tipo de fichero de búsqueda: todos los ficheros, R source files, R Scripts o tipo de fichero personalizado.

  3. Presionamos Find
  4. En los resultados de búsqueda encontraremos
  5. - En negrita la ruta del fichero.
    - El número de línea donde se encuentra la cadena de búsqueda.
    - Resaltada dentro de la línea la cadena de búsqueda.

  6. Doble clic en cualquiera de las líneas abrirá el fichero correspondiente, y situará el cursor al comienzo de la línea seleccionada.

Entradas relacionadas

2017-03-25

Listar ficheros de una carpeta en Excel

Title

Problema

Queremos listar los ficheros de una carpeta en Excel.

Solución

Empleamos un truco de John Walkenbach que leí hace bastante tiempo.

  1. Copiamos la ruta del explorador de Windows.
  2. La pegamos en la barra de direcciones de nuestro navegador y presionamos la tecla Entrar.
  3. Obtendremos el siguiente resultado (identificador de recursos uniforme.)
  4. Seleccionamos todo presionando Ctrl+A
  5. Abrimos un Excel y pegamos el resultado anterior presionando Ctrl+V. Si lo deseamos pegar como valores, presionamos Ctrl+Alt+V y seleccionamos Texto.
  6. Los hipervínculos funcionan cuando los pego desde Firefox pero no desde Chrome (precede las rutas duplicando el nombre de la unidad C:\C:\). Pero es algo que quizá cambie en función de la versión del navegador.

Entradas relacionadas

2017-03-17

Guardar un fichero Excel como un fichero CSV Unicode (UTF-8)


Title

Problema

Deseamos guardar un fichero Excel como un CSV codificado como UTF-8. De esta manera podremos representar cualquier caracter Unicode.

Solución

  1. Archivo, Guardar como o presionamos F12.
  2. Clic en Herramientas y en Opciones web.
  3. En Guardar este documento como, seleccionamos Unicode (UTF-8)
  4. En Tipo seleccionamos CSV (delimitado por comas).
  5. Clic en Aceptar y en Guardar tras seleccionar la ruta deseada.

Entradas relacionadas

2017-03-13

Convertir números a nombres de meses con Excel


Title

Problema

Queremos convertir los números a nombres de meses en Excel. Es decir, si hay un 1 queremos convertirlo a enero, o si hay un 12 a diciembre.

Solución

Empleamos la siguiente fórmula y arrastramos la fòrmula hacia abajo.

  • Abreviatura del mes
  • =TEXTO(FECHA(2017;B3;1);"mmm")

  • Nombre completo del mes
  • =TEXTO(FECHA(2017;B3;1);"mmmm")

Resultado

En la imagen aparece la versión de los meses en inglés, debido a la configuración de mi ordenador.

2017-03-06

Calcular la fecha de la Semana Santa en Excel


Title

Problema

Queremos calcular la fecha de la Semana Santa, en concreto, el Domingo de Resurrección en Excel.

Solución

Empleamos la siguiente fórmula de Norbert Hetterich, vinculada a la celda A2 en la que indicaremos el año deseado. La fórmula arroja solamente resultados válidos entre los años 1900 y 2078.

=MULTIPLO.INFERIOR.MAT(DIA(MINUTO(A2/38)/2+56)&"/5/"&A2,7)-34

Resultado

Referencias

Nube de datos